Can't save NVIDIA X Server Settings


GPU: GeForce 1080 TI

In my setup I am using the GPU both for model training as well as the primary driver for 3 monitors. When I go into NVIDIA X Server Settings I am able to configure the monitors how I wish and apply changes for the current session. However I am unable to save the settings to the X Configuration File and get the error:

Unable to open X config file ‘/etc/X11/xorg.conf’ for writing.

Additionally, I have tried manually writing this file with the proper config. However, on boot, it seems these settings are completely ignored. I have tried Googling the issues and tried various fixes (e.g. trying to manually trigger the NVIDIA X config load in .profile and other things) to no avail.

I did see an issue on the NVIDIA driver forums that suggested this might be a NVIDIA driver error that they have since patched. I don’t want to bump the version manually however as the entire point of the lambda stack is to ensure that the versions of all deps play well together.

Is this intended? I can surmise that maybe my issue is that I’m using my GPU to do drive my desktops as well as train and lambda stack expects you to use integrated graphics to drive your monitors? I don’t know.

Any thoughts?