How do I upgrade Lambda Stack from Ubuntu 16.04 to 18.04?

To upgrade from 16.04 LTS to 18.04 LTS simply run this command:

sudo apt-get update \
    && sudo apt-get dist-upgrade \
    && sudo apt-get autoremove \
    && sudo do-release-upgrade \
    && LAMBDA_REPO=$(mktemp) \
    && wget -O${LAMBDA_REPO} \
    && sudo dpkg -i ${LAMBDA_REPO} \
    && rm -f ${LAMBDA_REPO} \
    && sudo apt-get update \
    && sudo apt-get install -y lambda-stack-cuda \
    && echo 1>&2 "Please reboot now with `tput setaf 14`sudo reboot`tput sgr0`."

After all of that finishes, just sudo reboot and you’re done. Welcome to Ubuntu 18.04 LTS with Lambda Stack.

Will this work for a downgrade from 18.10 to 18.04 LTS? I found out the hard way horovod is hard/impossible to install on 18.10.

Unfortunately the easiest option for you will be to re-install Ubuntu.

I ran the code above and it seemed to have worked. When it was done I typed ‘sudo reboot’ as indicated. The system rebooted and now I am looking at the Ubuntu screen for the past two days. The dots change color which makes me think it is re-configuring itself. Is that correct? Will it come up into Linux at some point? Not sure what to do at this point.

As mentioned in the support thread, here’s the solution to that problem:

You need to boot into recovery mode, and then run:

apt-get update
apt-get install --fix-broken
apt-get dist-upgrade

You’ll need to bring your network interface up first. If you run

ip link show

you should see three interfaces (possibly more): “lo” (the loopback interface), and two that start with an e (these are the two ethernet ports on the motherboard).

Run these commands on both of the interfaces (since it will be difficult to figure out which is plugged in) to bring up the network.

ifup <interface name>
dhclient <interface name>

At that point, you should be able to ping Then you can run:

apt-get update
apt-get install --fix-broken
apt-get dist-upgrade

I seem to be stuck on

…there’s no evident way to accept the agreement, and “preparing to unpack […] libcudnn7” doesn’t progress.

If I try our old friend ‘nvidia-smi’

     rh@lambda-quad:~$ nvidia-smi
     Failed to initialize NVML: Driver/library version mismatch