What drivers/patches are necessary for the razer tensorbook?

Hello, I switched to another distro (NixOS) and I’m having some issues with sound. Desktop audio playback works, and so does the input/output when I plug in headphones, but the mic and output for things like OBS, Slack and Discord do not work. The options to select the mic and output are present but they don’t seem to be picking anything up. Screen sharing also just shows a black screen with the cursor in the middle.

What are the drivers needed for the razer tensorbook as described by Where can I download recovery images? | Lambda Docs in the recovery image page?

Current drivers are:

$ inxi -A                                                                        [22:47:24]
Audio:     Device-1: HDA NVidia driver: HDA-Intel 
           Device-2: sof-hda-dsp driver: sof-hda-dsp 
           Sound Server-1: ALSA v: k6.1.62 running: yes 
           Sound Server-2: PipeWire v: 0.3.80 running: yes 

Adding the full pulse audio package fixed the output when using apps like discord or slack via the browser.
For the mic I’ve found this, which looks to patch the mapping for the mic [BUG] microphone detected but not working on 2022 Razer Blade 15 · Issue #5989 · thesofproject/sof · GitHub but since I’m using NixOS, I’m not yet sure how to include the file correctly. Will likely have to use an overlay. If there is an already patched version of sof that the Lambda team was using, it would be helpful. Just posting my findings as they come, help is welcomed :slightly_smiling_face:

OK. Mic input is working, and chat outputs are also working. This is on discord/slack via Brave browser so should work on at least chromium based browsers.

My current config can be found here and the parts that fixed it are:

# mic input
  boot.extraModprobeConfig = ''
    options snd-sof-pci tplg_filename=sof-hda-generic-2ch-pdm1.tplg
# audio output from chat
hardware.pulseaudio.package = pkgs.pulseaudioFull;

I also enabled prime offloading and switch to the performance Nvidia driver, but that didn’t seem to be related necessarily.

Only thing that isn’t working now is screen sharing.

Looks like audio output works fine without changing the pulseaudio package. I’ve removed it and am using pipewire with pulse enabled instead. Still no screenshare.