Can not keep pace with Pytorch

I need to use Ubuntu 18.04 and run latest Pytorch on it. The lowest cuda version for the latest Pytorch 1.9.0 is 10.2. But it seems the highest cuda version Lambda stack support for Ubuntu 18,04 is 10.0. I tried to upgrade to 10.2 but can not. Can lambda stack update the cuda version to 10.2 or 11.0? Thanks.

1 Like

How can I update to the latest (or at least a more recent) version of PyTorch with Lambda Stack? On 2022.02.10 PyTorch is up to 1.10.2 and CUDA up to 11.3 per Start Locally | PyTorch.

I’ve a Lambda Labs Tensorbook. I tried upgrading my lambda stack with:

sudo apt-get update
sudo apt-get dist-upgrade

That succeeded. However

python3 -c "import torch;print(torch.__version__);print(torch.cuda.is_available());print(torch.cuda.get_device_name(torch.cuda.current_device()));"


NVIDIA GeForce RTX 2080 Super with Max-Q Design

which reveals the lambda-stack is using PyTorch 1.6.


nvcc --version


nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2019 NVIDIA Corporation
Built on Wed_Oct_23_19:24:38_PDT_2019
Cuda compilation tools, release 10.2, V10.2.89

which shows CUDA 10.2 in use.

Please help. I at least need Pytorch 1.8.


  1. I am guessing you are on Ubuntu 18.04 LTS.
    • So you can upgrade to 20.04 LTS
      (Ubuntu 22.04 releases around April).
      $ python3 -c “import torch;print(torch.version);print(torch.cuda.is_available());print(torch.cuda.get_device_name(torch.cuda.current_device()));”
      NVIDIA GeForce RTX 3080

    • You can use python venv, docker, virtualenv, or anaconda to run newer versions.
      I have write ups on how to run newer tensorflow, 2.7 + CUDA 11, on ubuntu 18.04 with docker or venv
      And a blog on the Anaconda use for that.

I cannot upload a text document to attach here. But I am open to sharing it, they worked for me and another person that needed that. And I could quick adapt that to pytorch.