Updated Lambda Stack and now have a PyTorch CuDNN version mismatch Error [resolved]

Hi all,

I just updated the packages on the Lambda Labs Quad (Ubuntu 18.04) via the recommended

 sudo apt-get update && sudo apt-get upgrade

The update included the recent cuDNN library etc. However, I run into the following issue now:

user@lambda-quad:~$ python3
Python 3.6.7 (default, Oct 22 2018, 11:32:17) 
[GCC 8.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import torch
>>> torch.backends.cudnn.version()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3/dist-packages/torch/backends/cudnn/__init__.py", line 65, in version
    if _libcudnn() is None:
  File "/usr/lib/python3/dist-packages/torch/backends/cudnn/__init__.py", line 58, in _libcudnn
    'but linked against {}'.format(compile_version, __cudnn_version))
RuntimeError: cuDNN version mismatch: PyTorch was compiled against 7201 but linked against 7301

Any tips for resolving this?

Sounds like you’re using a version of torch that’s not from Lambda Stack. You don’t need to manually install anything.
Run this command to get everything to the latest version:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get autoremove

Thanks. I think the issue was that I previously only ran

sudo apt-get update && sudo apt-get upgrade


sudo apt-get update && sudo apt-get upgrade && sudo apt-get autoremove

(I see that you recently also updated the lambda-instructions to that command).


Did that fix it for you?

I haven’t had a chance to test it yet but will try so ~Monday – have some multi-day computations running that I am worrying to disrupt by this. I will post here once I was able to check. Thanks!

The backends issue now seems to be resolved. I am still not able to upgrade to PyTorch 1.0 via the lambda-stack though (Lambda-Stack does not upgrade to PyTorch v 1.0 - Technical Help - DeepTalk - Deep Learning Community).

1 Like