Indirect rendering when using GLX from remote machine

Hi there:

I’m remoting into our machine (that contains 4 nvidia cards) using ssh -X machine.

I’m trying to get glxinfo working as an initial test for some further engine development and I’m getting the following error text after issuing glxinfo:

name of display: localhost:10.0
X Error of failed request: BadValue (integer parameter out of range for operation)_
Major opcode of failed request: 151 (GLX)_
Minor opcode of failed request: 24 (X_GLXCreateNewContext)_
Value in failed request: 0x0_
Serial number of failed request: 41_
Current serial number in output stream: 42_

After looking on the internet it appears to be that the support for X11 servers OpenGL indirection is not enabled on the lambda by default.

I’ve tried adding the below section to /usr/share/X11/xorg.conf.d/99-allow-indirect-glx.conf
Section “ServerFlags”
_ Option “AllowIndirectGLX” “on”_
_ Option “IndirectGLX” “on”_
_ EndSection_
typically that would be in /etc/X11 but I’m not seeing that file there.

So the two questions I have for support are:
1.) Is this truly an issue due to indirect rendering when you use GLX
from a remote machine?
2.) And if so, how can I enable indirect rendering on our Lambda machine?

Mike Ramsey

Figured it out, you need to modify 10-nvidia.conf. Works like a charm…sorta, at least for simple apps. Old drivers on the lambda hinders engine work.