New lambda tensorbook boots to black screen in Ubuntu and hangs; boots fine to Windows

Hi. I’m new here - can anyone help?

I have a new Tensorbook (bought this year). It has been working fine in Ubuntu and Windows (the latter of which I barely use). Today I woke up to find that it would no longer boot to Ubuntu. Before I get to the login screen, it gives the message “tpm tpm0: [Firmware bug]: TPM interrupt not working, polling instead”. Then the screen goes black and nothing further happens.

This occasionally happened before but the solution seemed to be to do a hard restart. Now nothing works.

Does anyone have any insights into how to fix this?


Does the windows os boot OK? Is it just the ubuntu?
What did you do prior? Any ubuntu update to the problematic 20.04 or .10
Any other clues?

i am having the same issue! Were you able to fix this? thanks

Does this happen when you suspend / hibernate on ubuntu?

You should also send an email to

Hi all,

If you could, please boot into the Ubuntu Recovery mode to get into a root shell and run the following:

sudo tee /etc/modprobe.d/tensorbook.conf && \
echo i915 | sudo tee -a /etc/initramfs-tools/modules && \
sudo sed -iE '/^GRUB_CMDLINE.*DEFAULT/ s/"$/ i8042.nomux"/' /etc/default/grub && \
sudo update-initramfs -u -k all && \
sudo update-grub

This should update all of the installed kernels. Reboot to ensure the fix worked and please let us know if you’re still encountering the issue, thanks!

I have a similar issue with my Tensorbook which is usually running Ubuntu 20.04 and Windows 10.

After doing a restart from Windows, which worked for one year without issues, today the laptop is stuck at the black screen with the white Lambda logo. The grub menu doesn’t show up at all anymore.

I also don’t know which key to use to boot from a usb drive to rescue all the data. Non of the F1 to F12 keys seems to work and also Del is doing nothing. How to access the boot menu or “Bios” or in general fix this boot issue?


If I’m not mistaken, you’ve recently submitted a support ticket for this, which I am responding to as well.

Continually pressing either F2 or DEL should bring you to the BIOS menu after rebooting. If this doesn’t work, please respond to the support ticket so that I may better assist you.

hello calvin sorry for the late reply!

I have entered recovery mode and tried to run the set of commands youve given but nothing seems to be happening after running them. Is that an issue on my end?

The issue that i am having is that after selection ubuntu from the BIOS i go through the screen with Lambda sign and then it stops at a black screen with _ repeatedly flashing. It does not go to the main page as it used to. The only way around this is so force shutdown my laptop and then go on to windows cause ubuntu doesnt work. Would appreciate any help on this.

Thank you have a good day.

Hello again,

When you’re at the black screen, are you able to use CTRL + ALT + F3 to open a new TTY?

If so, try running the commands again. If this doesn’t work, I’d highly recommend opening a support case with us so that we can better assist you. This can be done by emailing