RDP issues- Windows to Lambda Workstation (Ubuntu)

I am trying to RDP from my Windows laptop into the LambdaLabs quad Ubuntu 20.04. I can do it on the same network but am having issues when doing it over a several mile distance. I have tried disabling the firewall on both sides and still nothing. Any help would be appreciated.

Hi Nick,

The issue here is that your Lambda workstation doesn’t have a static, public facing IP for you to connect to when not on the same network. So when you’re attempting to connect to what would be your public IP, your router doesn’t know where to send that connection.

The solution for this would be to have a public facing Linux instance with a true public static IP. The easiest way to do this is to create a free AWS account and spin up a free AWS instance which will be used as a bridge for the SSH tunnel where you can basically forward the RDP port. I’ve personally never tried this as I’ve never had a need to, but it should be possible.

Scenario 1 might work for you (It’s written for port 3306 but 3389 should work as well) so the steps should still be similar enough.

Also, is there a specific reason why you’d need to RDP to your Ubuntu workstation or could you use SSH? I ask as Windows 10 now has powershell where you can perform Linux commands, including SSH. So I’d recommend SSHing as I have experience with this so setting up the SSH tunnel will be much more straight forward.

Hopefully this helps and please do let us know should you have any further questions or concerns. Also, to open a ticket with Lambda support, please email support@lambdal.com

Calvin Wallace
Linux Support Engineer