Updating cudatoolkit to 10.1

I am needing to update my cudatoolkit version from 10.0 (the version installed when I received my tensorbook) to 10.1 in order to use some of MATLAB’s gpuCoder capabilities. However, I am having a hard time figuring out how to uninstall the 10.0 version and trying to install more recent cuda versions on top of the existing one leads to errors I can’t seem to fix. I tried to update the lambda stack and while that did update several things it did not update the cuda version.

Output of nvidia-smi:
| NVIDIA-SMI 440.44 Driver Version: 440.44 CUDA Version: 10.2 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce RTX 207… On | 00000000:01:00.0 Off | N/A |
| N/A 46C P8 8W / N/A | 292MiB / 7982MiB | 6% Default |

Output of nvcc -V:
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2018 NVIDIA Corporation
Built on Sat_Aug_25_21:08:01_CDT_2018
Cuda compilation tools, release 10.0, V10.0.130

Output of which nvcc:

same problem here.
please advice.


Latest version of Lambda Stack seems to have 10.2. Can you do this:

sudo apt-get update && sudo apt-get upgrade

Let me know if that fixes your problem.

upgrading does not help. Somehow cuda toolkit is not updated or not present > 10.0

Any advice ?



If you try it now, you’ll be upgraded to CUDA 11. Does that solve your problem?

We support up to CUDA 10.0 on Ubuntu 16.04 & 18.04. We support all the way up to CUDA 10.2 on Ubuntu 20.04.
Run the following to upgrade to 20.04:

sudo sed -i '/^AutomaticLoginEnable/ s/true/false/' /etc/gdm3/custom.conf &&\
sudo apt -y update && sudo apt -y dist-upgrade && do-release-upgrade -d -f DistUpgradeViewNonInteractive

Once the update completes, reboot & reinstall Lambda Stack:

LAMBDA_REPO=$(mktemp) && \
wget -O${LAMBDA_REPO} https://lambdalabs.com/static/misc/lambda-stack-repo.deb && \
sudo dpkg -i ${LAMBDA_REPO} && rm -f ${LAMBDA_REPO} && \
sudo apt-get update && sudo apt-get install -y lambda-stack-cuda

I run the script

sudo sed -i ‘/^AutomaticLoginEnable/ s/true/false/’ /etc/gdm3/custom.conf &&
sudo apt -y update && sudo apt -y dist-upgrade && do-release-upgrade -d -f DistUpgradeViewNonInteractive

but now it’s still Ubuntu 18.04.5 LTS

This is probably one of the Python 2 dev packages.
Try removing them - sudo apt-get remove python-*-dev
Then try the release upgrade again.