Blank Monitor, but sound works for new Lambda Dual (Ubuntu)


I am trying to connect my brand new Lambda Dual with Ubuntu to my LG UltraFine 4K Display via USB-C (it is working fine with my MacBookPro). When I start the Lambda machine, the screen remains blank. After a few minutes, however, I can hear the Ubuntu start up sound (but the screen remains blank).

I also tried connecting with a USB-C Adapter to Display Port. However, that does not even give me the sound.

Any suggestions would be greatly appreciated.

Do you have a dual boot with Ubuntu and Windows? I have a similar setup and am having problems on the Ubuntu side. Windows display and sound works fine. I can utilize the GPUs without a problem as well. But once I get past the grubloader in Ubuntu I basically get a cursor and blank screen. If I override the Cuda drivers then the display works but that defeats the purpose of having a machine like this.

Thanks, for your answer. Unfortunately, I do not have a dual boot. I have now been able to narrow it down to problems with the drivers in Ubuntu as the Asus logo can be seen at the start. But I have not yet solved the issue…

Hey Leif, can you try plugging in your monitor into the top GPU’s USB-C instead of the motherboard? The motherboard doesn’t have USB-C graphics.

If that doesn’t fix it, please email and we’ll help out.