Ubuntu 18.04 shows a black screen after boot

I have a Lambda Quad machine, it was installed with Ubuntu 16.04, I tried to install ubuntu 18.04. however, after installation, and system boot, it just shows a black screen.

Hi Aminvision,

Can you try the following?

When you get to the GRUB boot loader (it looks like this):

Press e and then add this to the end of the linux line:


Then hit F10 key to boot into the Ubuntu system. You can then install Lambda Stack like so:

LAMBDA_REPO=$(mktemp) && \
wget -O${LAMBDA_REPO} https://lambdalabs.com/static/misc/lambda-stack-repo.deb && \
sudo dpkg -i ${LAMBDA_REPO} && rm -f ${LAMBDA_REPO} && \
sudo apt-get update && sudo apt-get install -y lambda-stack-cuda

This does not work at all! It solves nothing!

I have exactly the same problem, and I did your suggestions, unfortunately, it the problem remains.

@japos and @aminvision Were either of you able to ultimately solve your problem?

I got itnto the same problem. When I tried updating the grub, I got into different set of error, which starts with PKCS#7 Signature not signed witha trusted key and ends with EDAC Sbridge: Failed to register deivce with error -19.

All this happened after I tried to upgrade the OS, Ubuntu 18.04.

Any help to recover would be appreciated.

If you’ve got a Lambda system, you can email support@lambdalabs.com and they’ll help you fix it.