Reinstall of OS (22.04) on Vector Workstation

I ran in to some NVIDIA issues with other installed simulation software that has broken the installed OS on our Vector Workstation. I would like to reinstall the OS and the latest version of the Lamda stack. The problem is that I cannot get the system to boot into the Ubuntu installer.

I have followed the directions shown here to create a bootable USB stick with Ubuntu 22.04 Desktop.

This seems to work without issue. I then followed the directions shown in this post here to boot from the USB stick.

This will boot from the stick and drop me into the GRUB menu with an entry for “Try or Install Ubuntu.” Following the directions in the post, I edited the entry, adding nouveau.modeset=0 to the entry. Then, pressing F10, the system clears the screen, writes “Booting a command list” and then just sits there. The fans run and the main board displays the code AA, but it does not do anything.

If I try the same procedure above, but just choose “Try or Install Ubuntu” the system will briefly display a warning about no /boot and also just sit there. After spending several hours at this, I have gotten nowhere. Is there a definitive guide anywhere on the site that explains how to reload the OS from it’s base?

Have you tried using a Lambda recovery image?

Ok, tried that… does not work. I wrote the ISO to the USB stick, booted the workstation into the BIOS screen and selected the USB Drive as the boot override option. Instead of booting, a back rectangle comes up on the screen (in front of the BIOS screen) and then disappears, leaving me in the BIOS setup utility.

Clearly, there is something wrong with the way the disk image is being created on the USB Drive.

After spending just about the entire day with this, I simply don’t understand why this is so difficult. I guess the next step is going to try and burn a CD and boot from CD-ROM. Working with this machine and NVIDIA Drivers in general is quite frustrating.

Ok, so Friday didn’t end as a complete failure. I was able to finally get the Lamda restore image to work. I abandoned doing this on Linux as it seems the instructions just don’t work on the latest software. For other folks that may have a similar issue… I’ve include the steps. Not all of these may be necessary, but this is what worked for me.

  1. Download the Jammy recovery ISO from the link Cody provided above (thanks for that @cody_b, I did not know it existed).

  2. On MacOS, convert this .iso to .dmg using the following command:
    hdiutil convert lambda-recovery-jammy-20230704.iso -format UDRW -o lamda-recovery-jammy

  3. Using the Disk, format the the entire USB Drive on MacOS as MSDOS-FAT (my USB Drive is a 2TB crucial SSD)

  4. Open a terminal window and type diskutil list to find the drive device name. In my case, it was /dev/disk4. Make sure you get this right otherwise it could be disastrous.

  5. Unmount the disk using the command diskutil unmountDisk /dev/disk4

  6. Write the .dmg file to the USB Drive using the command as follows:
    sudo dd if=lamda-recovery-jammy.dmg of=/dev/disk4 bs=1m

After it’s done, you can then boot the vector workstation into the BIOS screen, select the USB Drive in the “boot override” menu, and it should boot right into the recovery image.

I am not sure why the equivalent commands on linux to write the image to the USB did not work or why this also did not work with the stock Ubuntu image.