External Monitors No longer working

I had two external monitors connected for a long time, one via the HDMI port and the second one via one of the USB-C ports, they both stopped working and no longer recognizes the external monitors.

  • I tried upgrading to Ubuntu Ubuntu 20.04.1 LTS to see if it could be old driver but still the same issue
  • I tried connecting via USB-C Hub and still doe snot recognizes them
  • xrandr --listmonitors does not see them
  • The UBS-C is connected via a HDMI to USB-C adapter, and it does recognize the adapter but still no monitor, here is the portion of dmesg:

[ 1532.681263] usb 1-1: USB disconnect, device number 17
[ 1538.017756] usb 1-2: new high-speed USB device number 18 using xhci_hcd
[ 1538.555023] usb 1-2: New USB device found, idVendor=2109, idProduct=0100, bcdDevice= 3.00
[ 1538.555029] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1538.555033] usb 1-2: Product: USB 2.0 BILLBOARD
[ 1538.555036] usb 1-2: Manufacturer: VIA Technologies Inc.
[ 1538.555039] usb 1-2: SerialNumber: 0000000000000001

I am at a loss since this used to work perfectly before, please help!

1 Like

Oh Forgot to add that the monitors work perfectly in a MacBook Pro, I always switch between the tow laptops depending on the type of work I am doing.

Try running the following to revert to the previous version of the NVidia driver, then reboot:

dpkg -l | awk '$2 ~ /-440/ { printf "%s=440.100-0ubuntu0.18.04.1\n", $2 }' |sudo xargs apt -y install  --allow-downgrades 

If your display doesn’t come back, could you run sudo nvidia-bug-report.sh and share the resulting “nvidia-bug-report.log.gz” file?